關於IP與連線
什麼是WHOIS
傳統註冊資訊查詢協定及其與RDAP的差異。
更新日期: 2026年10月9日
WHOIS是傳統的網域與IP註冊資訊查詢協定,通常使用TCP 43 Port,回傳文字格式可能依提供者而異。
與RDAP的差異
RDAP使用HTTPS與標準JSON,並改善國際化與存取控制。NetKarte優先使用RDAP,僅在IANA RDAP Bootstrap沒有該TLD時,才Fallback至固定允許清單中的官方Registry WHOIS,不會連線任意WHOIS Server或追蹤Referral。
聯絡資訊
公開範圍由Registry或Registrar決定。對於JP網域,JPRS WHOIS可能回傳註冊者名稱,以及公開聯絡窗口的姓名、電子郵件、地址、電話號碼等。NetKarte只向執行查詢的瀏覽器顯示官方回應中存在的非空欄位,不顯示完整的WHOIS原始回應。
NetKarte不會還原或推測依註冊者要求隱藏的資訊。隱藏說明連結固定指向JPRS官方頁面,不會將WHOIS回應中的任意URL用於該連結。
為什麼不同網域的結果不同
WHOIS提供者的欄位名稱、日期格式及公開政策各不相同。JPRS公開聯絡人可能是隱私代理服務,而不是註冊者本人。資訊隱藏不表示沒有註冊者。
NetKarte僅支援部分TLD的官方WHOIS。RDAP通訊失敗不會自動切換WHOIS,也不保證所有國家或網域都能成功。IP註冊資訊使用RDAP。
接下來檢查什麼
在網域資訊查詢的「網域」欄輸入目標網域,完成所需驗證後點選「查詢」。先確認「基本資訊」中的註冊網域,再查看「註冊管理機構」的「資訊來源」與「查詢伺服器」,判斷結果是否來自WHOIS。沒有手動選擇WHOIS的操作。「RDAP / WHOIS註冊資訊」中的註冊日期、更新日期、到期日期及「公開聯絡資訊」只顯示可取得的項目。
對照輸入與實際註冊網域,再查看來源、狀態及日期。要修改註冊資訊,請聯絡簽約的註冊商。遵守提供者的使用規定,不要蒐集公開信箱用於未經請求的行銷。
參考資料
- IETF / RFC Editor: RFC 3912: WHOIS Protocol Specification (外部網站)確認日期: 2026-10-09
- IETF / RFC Editor: RFC 9224: RDAP Bootstrap Service Registries (外部網站)確認日期: 2026-10-09
- IETF / RFC Editor: RFC 9083: RDAP Response Format (外部網站)確認日期: 2026-10-09
- JPRS: JPRS WHOIS利用方法 (外部網站)確認日期: 2026-10-01
- JPRS: JPRS WHOIS検索結果の見方 (外部網站)確認日期: 2026-10-09
- JPRS: JPドメイン名登録情報の非表示設定 (外部網站)確認日期: 2026-10-01