關於網域與DNS
什麼是DNS Lookup
說明DNS記錄查詢方式與結果閱讀方法。
更新日期: 2026年10月9日
DNS Lookup用於查詢網域的指定記錄類型。A、AAAA、MX與NS各有不同用途。
在NetKarte中確認
NetKarte由伺服器透過DNS over HTTPS查詢。NXDOMAIN表示名稱不存在,NODATA表示沒有指定類型。
注意事項
ALL會分別查詢支援的類型,並非傳統ANY查詢。
根據問題選擇類型
- 網站目標:A、AAAA;別名:CNAME。
- 郵件目標:MX;文字設定:TXT。
- DNS管理與區域:NS、SOA。
- 憑證簽發政策:CAA。
在DNS Lookup輸入名稱,選擇類型,完成驗證後查詢。ALL只查支援的8種類型,不探索未知子網域或所有DNS類型。多筆結果按記錄編號閱讀,全筆複製也按區塊進行。
失敗不等於未設定
無記錄時檢查名稱及類型;逾時或SERVFAIL不是未設定的證據。Cloudflare回答及短期快取可能與企業DNS不同。也可輸入_dmarc.example.com等含底線的DNS名稱。
參考資料
- IETF / RFC Editor: RFC 1034: Domain Names - Concepts and Facilities (外部網站)確認日期: 2026-10-09
- IETF / RFC Editor: RFC 1035: Domain Names - Implementation and Specification (外部網站)確認日期: 2026-10-09
- IETF / RFC Editor: RFC 8484: DNS Queries over HTTPS (外部網站)確認日期: 2026-10-09
- Cloudflare: DNS over HTTPS (外部網站)確認日期: 2026-10-01