关于IP与连接
什么是RDAP
用于查询IP地址和域名注册信息的标准JSON协议。
更新日期: 2026年10月9日
RDAP通过HTTPS和结构化JSON提供IP地址与域名的公开注册信息,比格式因服务商而异的WHOIS文本更便于处理。
查询方式
NetKarte根据IANA Bootstrap选择负责的RIR或Registry,并仅由服务器访问其官方端点。用户不能指定任意URL。
注意事项
注册信息不能证明当前用户身份或实际位置。对于已隐藏的联系信息,NetKarte不会推测或补全。
先确认注册单位
查询IP时,在IP信息查询的“IP地址”栏输入目标;查询域名时,使用域名信息查询的“域名”栏。完成所需验证并点击“查询”,先在“基本信息”确认目标,再阅读“RDAP / WHOIS注册信息”。域名查询还应查看“注册管理机构”中的“信息来源”,确认使用的是RDAP还是WHOIS。这与自动显示当前连接的网络诊断是不同的查询功能。
查询IP时,依次阅读目标、网络范围、注册组织。一个IP可能属于较大的注册网段。CIDR前缀表示范围,不是实际设备数量。
查询域名时,查看注册域名、注册商及注册、更新、到期事件。注册信息更新日期不是网站正文更新日期。
只有注册信息获取失败时
本地GeoIP可以成功,而外部RDAP仍可能失败。RDAP / WHOIS注册信息部分的错误只针对该部分,与联系人隐藏或目标未找到不同。请稍后重试,不要连续反复查询。
参考资料
- IETF / RFC Editor: RFC 9224: RDAP Bootstrap Service Registries (外部网站)确认日期: 2026-10-09
- IETF / RFC Editor: RFC 9082: RDAP Query Format (外部网站)确认日期: 2026-10-09
- IETF / RFC Editor: RFC 9083: RDAP Response Format (外部网站)确认日期: 2026-10-09